<!DOCTYPE html>
<html lang="en" xmlns:fb="http://ogp.me/ns/fb#">
	<head><script src="/gdpr/gdprscript.js?buildTime=1535751170&hasRemindMe=true&stealth=false"></script>
		<title>Current Miami Dolphins 53-man roster overview - PhinManiacs.com</title><meta property="og:site_name" content="PhinManiacs.com" />
<meta property="og:title" content="Current Miami Dolphins 53-man roster overview" />
<meta property="og:description" content="​It’s September 1st, and that means two things: It’s cut-down day, and suddenly every fanbase wants every single player that’s been cut. Today is the day that every front office hopes to find the treasure in another team’s trash, per say." />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/1023457708-jpg-0_orig.jpg" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/ryan-tannehill-header-3_orig.jpg" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/kenyan-drake-header-3_orig.jpg" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/devante-parker-header-6_1_orig.jpg" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/20180825-dolphins-ravens-040_orig.jpg" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/ja-wuan-james-header-1_1_orig.jpg" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/cameron-wake-header-4_orig.jpg" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/jordan-phillips-header-1_orig.png" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/raekwon-mcmillan-header-2_orig.jpg" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/xavien-howard-header-3_3_orig.png" />
<meta property="og:url" content="http://www.phinmaniacs.com/9/post/2018/09/current-miami-dolphins-53-man-roster-overview.html" />
<meta http-equiv='cache-control' content='no-cache' />
<meta property="description" content="​It’s September 1st, and that means two things: It’s cut-down day, and suddenly every fanbase wants every single player that’s been cut. Today is the day that every front office hopes to find the treasure in another team’s trash, per say." />



<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1.0"/>

		<script type="text/javascript">var GBMobileURL = 'http://mobile.phinmaniacs.com';</script>
<script type="text/javascript" src="http://mobile.phinmaniacs.com/assets/js/detectmobilebrowser.js"></script>

<P> <CENTER>

<script src="https://www.googletagservices.com/tag/js/gpt.js">  googletag.pubads().definePassback("/20893548/yb/phinmaniacs",[728,90]).setClickUrl("%%CLICK_URL_UNESC%%").display(); </script>

<p>
		<link id="wsite-base-style" rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/sites.css?buildTime=1535751170" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/old/fancybox.css?1535751170" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/social-icons.css?buildtime=1535751170" media="screen,projection" />
<link rel="stylesheet" type="text/css" href="/files/main_style.css?1535755344" title="wsite-theme-css" />
<link href='//fonts.googleapis.com/css?family=Raleway:400,300,200,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Lora:400,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />

<link href='//fonts.googleapis.com/css?family=Droid+Sans:400,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//cdn2.editmysite.com/fonts/Saginaw/font.css?2' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Oswald:400,300,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Oswald:400,300,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Playfair+Display:400,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Montserrat:400,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Raleway:400,300,200,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<style type='text/css'>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</style>
<style>
.wsite-background {background-image: url("/uploads/5/7/1/9/57193657/background-images/1366250879.jpg") !important;background-repeat: no-repeat !important;background-position: 50.00% 56.12% !important;background-size: 100% !important;background-color: transparent !important;}
body.wsite-background {background-attachment: fixed !important;}.wsite-background.wsite-custom-background{ background-size: cover !important}
</style>
		<script src='/files/templateArtifacts.js?1535755344'></script>
<script>
var STATIC_BASE = '//cdn1.editmysite.com/';
var ASSETS_BASE = '//cdn2.editmysite.com/';
var STYLE_PREFIX = 'wsite';
</script>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js'></script>

<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1535751170&"></script>
<script src="//cdn2.editmysite.com/js/site/main.js?buildTime=1535751170"></script><script type="text/javascript">
		function initCustomerAccountsModels() {
					(function(){_W.setup_rpc({"url":"\/ajax\/api\/JsonRPC\/CustomerAccounts\/","actions":{"CustomerAccounts":[{"name":"login","len":2,"multiple":false,"standalone":false},{"name":"logout","len":0,"multiple":false,"standalone":false},{"name":"getSessionDetails","len":0,"multiple":false,"standalone":false},{"name":"getAccountDetails","len":0,"multiple":false,"standalone":false},{"name":"getOrders","len":0,"multiple":false,"standalone":false},{"name":"register","len":4,"multiple":false,"standalone":false},{"name":"emailExists","len":1,"multiple":false,"standalone":false},{"name":"passwordReset","len":1,"multiple":false,"standalone":false},{"name":"passwordUpdate","len":3,"multiple":false,"standalone":false},{"name":"validateSession","len":1,"multiple":false,"standalone":false}]},"namespace":"_W.CustomerAccounts.RPC"});
_W.setup_model_rpc({"rpc_namespace":"_W.CustomerAccounts.RPC","model_namespace":"_W.CustomerAccounts.BackboneModelData","collection_namespace":"_W.CustomerAccounts.BackboneCollectionData","bootstrap_namespace":"_W.CustomerAccounts.BackboneBootstrap","models":{"CustomerAccounts":{"_class":"CustomerAccounts.Model.CustomerAccounts","defaults":null,"validation":null,"types":null,"idAttribute":null,"keydefs":null}},"collections":{"CustomerAccounts":{"_class":"CustomerAccounts.Collection.CustomerAccounts"}},"bootstrap":[]});
})();
		}
		if(document.createEvent && document.addEventListener) {
			var initEvt = document.createEvent('Event');
			initEvt.initEvent('customerAccountsModelsInitialized', true, false);
			document.dispatchEvent(initEvt);
		} else if(document.documentElement.initCustomerAccountsModels === 0){
			document.documentElement.initCustomerAccountsModels++
		}
		</script>
		<script type="text/javascript"> _W = _W || {}; _W.securePrefix='www.phinmaniacs.com'; </script><script>_W = _W || {};
			_W.customerLocale = "en_US";
			_W.storeName = null;
			_W.storeCountry = "US";
			_W.storeCurrency = "USD";
			_W.storeEuPrivacyPolicyUrl = "";
			com_currentSite = "722064618805177267";
			com_userID = "57193657";</script><script type="text/javascript">_W.configDomain = "www.weebly.com";</script><script>_W.relinquish && _W.relinquish()</script>
<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1535751170&"></script><script> _W.themePlugins = [];</script><script type="text/javascript"> _W.recaptchaUrl = "https://www.google.com/recaptcha/api.js"; </script><script type="text/javascript"> window._W = window._W || {}; _W.showV2Footer = ; </script><script type="text/javascript"><!--
	
	var DISABLE_NAV_MORE = 1;
	function initFlyouts(){
		initPublishedFlyoutMenus(
			[{"id":"532739273594404999","title":"Home","url":"index.html","target":"","nav_menu":false,"nonclickable":false},{"id":"332450421721364753","title":"Community Coverage","url":"community-coverage.html","target":"","nav_menu":false,"nonclickable":false},{"id":"407278629557088076","title":"Fantasy","url":"fantasy.html","target":"","nav_menu":false,"nonclickable":false},{"id":"349314906477217206","title":"Film Analysis","url":"film-analysis.html","target":"","nav_menu":false,"nonclickable":false},{"id":"424109574749656784","title":"Newswire","url":"newswire.html","target":"","nav_menu":false,"nonclickable":false},{"id":"532035896267061933","title":"Opinion","url":"opinion.html","target":"","nav_menu":false,"nonclickable":false},{"id":"496326006531464521","title":"Podcasts","url":"podcasts.html","target":"","nav_menu":false,"nonclickable":false},{"id":"994901722224474276","title":"Schedule","url":"schedule.html","target":"","nav_menu":false,"nonclickable":false}],
			"833769335793861018",
			'',
			'active',
			false,
			{"navigation\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}} class=\"wsite-menu-item-wrap\">\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\t{{#membership_required}}\n\t\t\tdata-membership-required=\"{{.}}\"\n\t\t{{\/membership_required}}\n\t\tclass=\"wsite-menu-item\"\n\t\t>\n\t\t{{{title_html}}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n","navigation\/flyout\/list":"<div class=\"wsite-menu-wrap\" style=\"display:none\">\n\t<ul class=\"wsite-menu\">\n\t\t{{#children}}{{> navigation\/flyout\/item}}{{\/children}}\n\t<\/ul>\n<\/div>\n","navigation\/flyout\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}}\n\tclass=\"wsite-menu-subitem-wrap {{#is_current}}wsite-nav-current{{\/is_current}}\"\n\t>\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\tclass=\"wsite-menu-subitem\"\n\t\t>\n\t\t<span class=\"wsite-menu-title\">\n\t\t\t{{{title_html}}}\n\t\t<\/span>{{#has_children}}<span class=\"wsite-menu-arrow\">&gt;<\/span>{{\/has_children}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n"},
			{}
		)
	}
//-->
</script>
		
		
	</head>
	<body class="no-header  wsite-page-news wsite-blog-post  full-width-on  wsite-theme-light"><div class="body-wrap">

	<div id="header">
		<div class="nav-trigger hamburger">
			<div class="open-btn">
				<span class="mobile"></span>
				<span class="mobile"></span>
				<span class="mobile"></span>
			</div>
		</div>
		<div id="sitename"><span class="wsite-logo">

	<a href="/">
		<img src="/uploads/5/7/1/9/57193657/published/ujqmeosm_1.png?1489034113" alt="PhinManiacs.com" />
	</a>

</span></div>
	</div>

	<div id="wrapper">
		<div class="bg-wrapper">
			<div id="navigation"><ul class="wsite-menu-default">
		<li id="pg532739273594404999" class="wsite-menu-item-wrap">
			<a
						href="/"
				class="wsite-menu-item"
				>
				Home
			</a>
			
		</li>
		<li id="pg332450421721364753" class="wsite-menu-item-wrap">
			<a
						href="/community-coverage.html"
				class="wsite-menu-item"
				>
				Community Coverage
			</a>
			
		</li>
		<li id="pg407278629557088076" class="wsite-menu-item-wrap">
			<a
						href="/fantasy.html"
				class="wsite-menu-item"
				>
				Fantasy
			</a>
			<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-731216350653461383"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="/fantasy-rankings.html"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Fantasy Rankings
		</span>
	</a>
	
</li>

	</ul>
</div>

		</li>
		<li id="pg349314906477217206" class="wsite-menu-item-wrap">
			<a
						href="/film-analysis.html"
				class="wsite-menu-item"
				>
				Film Analysis
			</a>
			
		</li>
		<li id="pg424109574749656784" class="wsite-menu-item-wrap">
			<a
						href="/newswire.html"
				class="wsite-menu-item"
				>
				Newswire
			</a>
			
		</li>
		<li id="pg532035896267061933" class="wsite-menu-item-wrap">
			<a
						href="/opinion.html"
				class="wsite-menu-item"
				>
				Opinion
			</a>
			
		</li>
		<li id="pg496326006531464521" class="wsite-menu-item-wrap">
			<a
						href="/podcasts.html"
				class="wsite-menu-item"
				>
				Podcasts
			</a>
			
		</li>
		<li id="pg994901722224474276" class="wsite-menu-item-wrap">
			<a
						href="/schedule.html"
				class="wsite-menu-item"
				>
				Schedule
			</a>
			
		</li>
</ul>
</div>
			<div id="content-wrapper">
				<div class="wsite-section-content">
					<div class="container"><div class="wsite-elements wsite-not-footer">
	<table 
	id="blogTable" 
		class="wsite-not-footer" 
	style="border: 0; width: 100%; table-layout: fixed" 
>
	<tr>
	    <td valign="top">
	        	<div id="833769335793861018-blog" class="blog-body" style="float: left;"> 
		<div id="wsite-content">	<div id="blog-post-404943339777927893" class="blog-post">
	
	
		<div class="blog-header">
			<h2 class="blog-title">
					<a class="blog-title-link blog-link" href="//www.phinmaniacs.com/news/current-miami-dolphins-53-man-roster-overview">Current Miami Dolphins 53-man roster overview</a>

			</h2>
			<p class="blog-date">
					<span class="date-text">
		9/1/2018
	</span>

			</p>
			<p class="blog-comments">
					<a href="//www.phinmaniacs.com/news/current-miami-dolphins-53-man-roster-overview#comments" class="blog-link">
		<fb:comments-count href="//www.phinmaniacs.com/news/current-miami-dolphins-53-man-roster-overview"></fb:comments-count> <span class="fb_comment_count_label">Comments</span>
	</a>

			</p>
		</div>
	
		<div class="blog-separator">&nbsp;</div>
	
		<div class="blog-content">
				<div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/1023457708-jpg-0_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph">&#8203;It&rsquo;s September 1st, and that means two things: It&rsquo;s cut-down day, and suddenly every fanbase wants every single player that&rsquo;s been cut. Today is the day that every front office hopes to find the treasure in another team&rsquo;s trash, per say.<br />&nbsp;<br />Although there is little doubt&mdash;it&rsquo;s really a certainty&mdash;that this roster will continue to change, here is the current 53-man roster:</div>  <h2 class="wsite-content-title"><strong><font size="5">Quarterbacks (3)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/ryan-tannehill-header-3_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Ryan Tannehill</strong></li><li><strong>Brock Osweiler</strong></li><li><strong>David Fales</strong></li></ol><strong><br />My take: </strong>I do not believe any team will trade for one of the backups; with that being said, if the Dolphins want to add someone, I might look at cutting QB3 to make the necessary space needed.</div>  <h2 class="wsite-content-title"><strong><font size="5">Running Backs (4)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/kenyan-drake-header-3_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Kenyan Drake</strong></li><li><strong>Frank Gore</strong></li><li><strong>Kalen Ballage</strong></li><li><strong>Senorise Perry</strong></li></ol><strong><br />My take:</strong> One of the better groups on the roster, I can eventually see Ballage taking more carries than Gore. Nonetheless, even if that does not occur this group is dynamic and will be one of the more exciting ones to monitor.<br /></div>  <h2 class="wsite-content-title"><strong><font size="5">Wide Receivers (5)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/devante-parker-header-6_1_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Kenny Stills</strong></li><li><strong>DeVante Parker</strong></li><li><strong>Danny Amendola</strong></li><li><strong>Albert Wilson</strong></li><li><strong>Jakeem Grant</strong></li></ol><br /><strong>My take: </strong>The team carrying only five wide receivers heading into Week 1 speaks to their confidence that both DeVante Parker and Jakeem Grant are healthy enough to play vs. Tennessee. Some tough cuts were made in this group, highlighted by Leonte Carroo and Isaiah Ford.&nbsp;</div>  <h2 class="wsite-content-title"><strong><font size="5">Tight Ends (4)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/20180825-dolphins-ravens-040_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Mike Gesicki</strong></li><li><strong>A.J. Derby</strong></li><li><strong>MarQueis Gray</strong></li><li><strong>Durham Smythe</strong></li></ol><strong><br />My take: </strong>This group may become dynamic, or be entirely absent. Yes, I know that&rsquo;s not much of a prediction, but the point is that it&rsquo;s volatile. Most depends on Mike Gesicki and how he develops (and how quickly). FWIW: in my prediction of first touchdown for the season, I chose A.J. Derby.<br />&nbsp;<br />Lastly, Clive Walford was part of cuts from the New York Jets&hellip;and as a Hurricane, I have to say&hellip;I want him.&nbsp;</div>  <h2 class="wsite-content-title"><strong><font size="5">Offensive Line (9)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/ja-wuan-james-header-1_1_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Josh Sitton</strong></li><li><strong>Laremy Tunsil</strong></li><li><strong>Daniel Kilgore</strong></li><li><strong>Ja'Wuan James</strong></li><li><strong>Jesse Davis</strong></li><li><strong>Sam Young</strong></li><li><strong>Ted Larsen</strong></li><li><strong>Zach Sterup</strong></li><li><strong>Jake Brendel</strong></li></ol><br /><strong>&#8203;My take: </strong>Another solid group, with solid depth. Which is odd to say about the Dolphins. I&rsquo;m fully aware of the questions and concerns, I have them too; but the point is simple&hellip;this is the best OL group on paper that Miami has put in front of Ryan Tannehill <em>ever.</em></div>  <h2 class="wsite-content-title"><strong><font size="5">Defensive Ends (5)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/cameron-wake-header-4_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Cameron Wake</strong></li><li><strong>Charles Harris</strong></li><li><strong>Robert Quinn</strong></li><li><strong>William Hayes (who I would also play inside)</strong></li><li><strong>Andre Branch</strong></li></ol><strong><br />My take: </strong>The best defensive group, and it&rsquo;s not close. Wake and Quinn can be dominant, and a depth of Hayes, Harris, and Branch is one of the better&mdash;if not the best&mdash;depth groups in football. Also, be on the lookout for Kendall Langford (also considered a DT) to be potentially signed back post-cuts. This move saves the Dolphins a significant amount of money.&nbsp;<br /></div>  <h2 class="wsite-content-title"><strong><font size="5">Defensive Tackles (4)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/jordan-phillips-header-1_orig.png" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Jordan Phillips</strong></li><li><strong>Vincent Taylor</strong></li><li><strong>Akeem Spence</strong></li><li><strong>Davon Godchaux</strong></li></ol><strong><br />My take: </strong>The group that&rsquo;s left to replace the immortal shoes of Suh. Will they be able to rotate, stay healthy, and produce? Not sure. But there are worse DT groups in the league, and being able to remain a middle of the pack DT group, even after losing Suh, is impressive.&nbsp;<br /></div>  <h2 class="wsite-content-title"><strong><font size="5">Linebackers (5)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/raekwon-mcmillan-header-2_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Raekwon McMillan</strong></li><li><strong>Kiko Alonso</strong></li><li><strong>Jerome Baker</strong></li><li><strong>Chase Allen</strong></li><li><strong>Stephone Anthony</strong></li><li><strong><em>Mike Hull</em> <em>(injured reserve)</em></strong></li></ol><br /><span style="color:rgb(20, 23, 26)"><strong>My take: </strong>Linebackers&hellip;what can I say? There&rsquo;s reason for hope (i.e. McMillan and Baker), but there is also cause for great concern (i.e. unproven talent, Alonso&rsquo;s decline, questionable depth). This is another group who would benefit from a claimed player. My gut tells me that we won&rsquo;t see much of a change prior to Week 1, but that isn&rsquo;t to say that Gase and co. should stop looking.</span></div>  <h2 class="wsite-content-title"><strong><font size="5">Cornerbacks (6)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/xavien-howard-header-3_3_orig.png" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Xavien Howard</strong></li><li><strong>Bobby McCain</strong></li><li><strong>Minkah Fitzpatrick (Safety hybrid)</strong></li><li><strong>Torry McTyer</strong></li><li><strong>Cornell Armstrong</strong></li><li><strong>Cordrea Tankersley</strong></li></ol><strong><br />My take: </strong>The most disappointing unit of the offseason and camp thus far. If there is a position which Gase and co. should be looking to upgrade, look no further than the CB group. Armstrong and McTyer have made the team at the moment, but not so certain they are there on Week 1. Keep your eyes out on the waiver wire for CB. Lippett was the big cut here.&nbsp;</div>  <h2 class="wsite-content-title"><strong><font size="5">Safety (4)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/reshad-jones-header-2_1_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Reshad Jones</strong></li><li><strong>T.J. McDonald</strong></li><li><strong>Maurice Smith</strong></li><li><strong>Walt Aikens</strong></li></ol><strong><br />My take:</strong> You have a dynamic safety in Jones, a dynamic special teamer in Aikens, and a young developmental player in Maurice Smith that deserved a spot on this team. Overall, this group has talent and projectability; I am uncertain if this will change prior to Week 1, but if not&hellip;they are in a good place.&nbsp;<br /></div>  <h2 class="wsite-content-title"><strong><font size="5">Special Teams (3)</font></strong></h2>  <div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/460871404-0_orig.jpg" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph"><ol><li><strong>Matt Haack (Punter)</strong></li><li><strong>Jason Sanders (Kicker)</strong></li><li><strong>John Denney (Long Snapper)</strong></li></ol><br /><strong>My take: </strong>What's to say? Everything went as expected.<br /><br /><strong><font size="3">Current Roster: 52/53</font></strong><br /><br /><strong>This story was written by Daniel Martinez. Follow him on Twitter: <a href="https://twitter.com/all_right_Miami" target="_blank">@all_right_Miami</a></strong></div>

		</div>
	
	
			<div class="blog-social  ">
		<div class="blog-social-item blog-fb-like"><fb:like href="http://www.phinmaniacs.com/9/post/2018/09/current-miami-dolphins-53-man-roster-overview.html" width="90" layout="button_count" action="like" show_faces="false" share="false"></fb:like></div><div class="blog-social-item"><a class="twitter-share-button" href="http://twitter.com/share?url=http://www.phinmaniacs.com/9/post/2018/09/current-miami-dolphins-53-man-roster-overview.html" data-text="Current Miami Dolphins 53-man roster overview - PhinManiacs.com" data-count="horizontal"></a></div>
		<div style="clear:both"></div>
	</div>

	
		<div class="blog-comments-bottom">
				<a href="//www.phinmaniacs.com/news/current-miami-dolphins-53-man-roster-overview#comments" class="blog-link">
		<fb:comments-count href="//www.phinmaniacs.com/news/current-miami-dolphins-53-man-roster-overview"></fb:comments-count> <span class="fb_comment_count_label">Comments</span>
	</a>

		</div>
	
		<div class="blog-post-separator"></div>
	</div>


    <a name="comments" id="comments"></a>
<div id="commentArea">
	<div class="blog-comment-area">
				<fb:comments 
			href="http://www.phinmaniacs.com/news/current-miami-dolphins-53-man-roster-overview"
			numposts="50" 
			order_by="reverse_time" 
			colorscheme="light" 
			class="facebook-comment-widget"
			width="100%"
		></fb:comments>



	</div>
	<!-- bid-1: , path:  -->
</div>
 
<!-- bid: $blog_id --></div>
	</div>

	    </td>
	        <td class="blog-sidebar" valign="top">
	            <div id="833769335793861018-sidebar" class="column-blog">
	<div class="blog-sidebar-separator">
		<ul id="833769335793861018-sidebar-list" class="columnlist-blog" style="margin:0; padding: 0;">
			<div><div id="714951839612077782" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><!-- start feedwind code --><script type="text/javascript">document.write('<script type="text/javascript" src="' + ('https:' == document.location.protocol ? 'https://' : 'http://') + 'feed.mikle.com/js/rssmikle.js"><' + '/script>');</script><script type="text/javascript">(function() {var params = {rssmikle_url: "http://www.phinmaniacs.com/9/feed",rssmikle_frame_width: "200",rssmikle_frame_height: "325",rssmikle_target: "_top",rssmikle_font: "Arial",rssmikle_font_size: "12",rssmikle_border: "on",responsive: "off",rssmikle_css_url: "",text_align: "left",text_align2: "left",corner: "on",scrollbar: "on",autoscroll: "off",scrolldirection: "up",scrollstep: "5",mcspeed: "30",sort: "New",rssmikle_title: "off",rssmikle_title_sentence: "",rssmikle_title_link: "",rssmikle_title_bgcolor: "#0066FF",rssmikle_title_color: "#FFFFFF",rssmikle_title_bgimage: "",rssmikle_item_bgcolor: "#FFFFFF",rssmikle_item_bgimage: "",rssmikle_item_title_length: "275",rssmikle_item_title_color: "#347093",rssmikle_item_border_bottom: "on",rssmikle_item_description: "title_only",item_link: "off",rssmikle_item_description_length: "150",rssmikle_item_description_color: "#8B8B8B",rssmikle_item_date: "gl2",rssmikle_timezone: "America/Toronto",datetime_format: "%b %e, %Y %l:%M:%S %p",item_description_style: "text",item_thumbnail: "full",article_num: "35",rssmikle_item_podcast: "off",keyword_inc: "",keyword_exc: ""};feedwind_show_widget_iframe(params);})();</script></div>



</div>

<h2 class="wsite-content-title" style="text-align:left;"><font size="4">Latest Dolphins News</font></h2>

<div class="wsite-spacer" style="height:10px;"></div>

<div class="wsite-spacer" style="height:10px;"></div>

<div><div id="242556355631298790" align="center" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><script src="https://www.googletagservices.com/tag/js/gpt.js"> googletag.pubads().definePassback("/20893548/yb/phinmaniacs", [160,600]).setClickUrl("%%CLICK_URL_UNESC%%").display(); </script></div>



</div>

<h2 class="blog-category-title" style="text-align:left;"><font size="4">PhinManiacs Columnists</font></h2>
<p class="blog-category-list">
	<a href="/news/category/all" class="blog-link">All</a>
	<br />
		<a href="/news/category/brandon-liguori" class="blog-link">Brandon Liguori</a>
		<br />
		<a href="/news/category/carlos-hernandez" class="blog-link">Carlos Hernandez</a>
		<br />
		<a href="/news/category/chad-ronnebaum" class="blog-link">Chad Ronnebaum</a>
		<br />
		<a href="/news/category/community-coverage" class="blog-link">Community Coverage</a>
		<br />
		<a href="/news/category/daniel-gamboa" class="blog-link">Daniel Gamboa</a>
		<br />
		<a href="/news/category/daniel-martinez" class="blog-link">Daniel Martinez</a>
		<br />
		<a href="/news/category/efrain-ramos" class="blog-link">Efrain Ramos</a>
		<br />
		<a href="/news/category/Eldon Jenson" class="blog-link">Eldon Jenson</a>
		<br />
		<a href="/news/category/eldon-jenson" class="blog-link">Eldon Jenson</a>
		<br />
		<a href="/news/category/fantasy-football" class="blog-link">Fantasy Football</a>
		<br />
		<a href="/news/category/film-analysis" class="blog-link">Film Analysis</a>
		<br />
		<a href="/news/category/ian-berger" class="blog-link">Ian Berger</a>
		<br />
		<a href="/news/category/lake-prasad" class="blog-link">Lake-prasad</a>
		<br />
		<a href="/news/category/luis-sung" class="blog-link">Luis Sung</a>
		<br />
		<a href="/news/category/matthew-knowles" class="blog-link">Matthew Knowles</a>
		<br />
		<a href="/news/category/miami-dolphins-cheerleaders" class="blog-link">Miami-dolphins-cheerleaders</a>
		<br />
		<a href="/news/category/nate-tucek" class="blog-link">Nate-tucek</a>
		<br />
		<a href="/news/category/neal-driscoll" class="blog-link">Neal-driscoll</a>
		<br />
		<a href="/news/category/opinion" class="blog-link">Opinion</a>
		<br />
		<a href="/news/category/phinmaniacs-podcast" class="blog-link">Phinmaniacs Podcast</a>
		<br />
		<a href="/news/category/press-releases" class="blog-link">Press-releases</a>
		<br />
		<a href="/news/category/richard-wilt" class="blog-link">Richard Wilt</a>
		<br />
		<a href="/news/category/ron-canniff" class="blog-link">Ron Canniff</a>
		<br />
		<a href="/news/category/seth-fisher" class="blog-link">Seth Fisher</a>
		<br />
		<a href="/news/category/tom-shannon" class="blog-link">Tom Shannon</a>
		<br />
		<a href="/news/category/voice-of-the-fan" class="blog-link">Voice Of The Fan</a>
		<br />
</p>

<h2 class="blog-archives-title" style="text-align:left;"><font size="3">Story Archives</font></h2>
<p class="blog-archive-list">
		<a href="/news/archives/08-2018" class="blog-link">August 2018</a>
		<br />
		<a href="/news/archives/07-2018" class="blog-link">July 2018</a>
		<br />
		<a href="/news/archives/06-2018" class="blog-link">June 2018</a>
		<br />
		<a href="/news/archives/05-2018" class="blog-link">May 2018</a>
		<br />
		<a href="/news/archives/04-2018" class="blog-link">April 2018</a>
		<br />
		<a href="/news/archives/03-2018" class="blog-link">March 2018</a>
		<br />
		<a href="/news/archives/02-2018" class="blog-link">February 2018</a>
		<br />
		<a href="/news/archives/01-2018" class="blog-link">January 2018</a>
		<br />
		<a href="/news/archives/11-2017" class="blog-link">November 2017</a>
		<br />
		<a href="/news/archives/10-2017" class="blog-link">October 2017</a>
		<br />
		<a href="/news/archives/09-2017" class="blog-link">September 2017</a>
		<br />
		<a href="/news/archives/08-2017" class="blog-link">August 2017</a>
		<br />
		<a href="/news/archives/07-2017" class="blog-link">July 2017</a>
		<br />
		<a href="/news/archives/06-2017" class="blog-link">June 2017</a>
		<br />
		<a href="/news/archives/05-2017" class="blog-link">May 2017</a>
		<br />
		<a href="/news/archives/04-2017" class="blog-link">April 2017</a>
		<br />
		<a href="/news/archives/03-2017" class="blog-link">March 2017</a>
		<br />
		<a href="/news/archives/02-2017" class="blog-link">February 2017</a>
		<br />
		<a href="/news/archives/01-2017" class="blog-link">January 2017</a>
		<br />
		<a href="/news/archives/12-2016" class="blog-link">December 2016</a>
		<br />
		<a href="/news/archives/11-2016" class="blog-link">November 2016</a>
		<br />
		<a href="/news/archives/10-2016" class="blog-link">October 2016</a>
		<br />
		<a href="/news/archives/09-2016" class="blog-link">September 2016</a>
		<br />
		<a href="/news/archives/08-2016" class="blog-link">August 2016</a>
		<br />
		<a href="/news/archives/07-2016" class="blog-link">July 2016</a>
		<br />
		<a href="/news/archives/06-2016" class="blog-link">June 2016</a>
		<br />
		<a href="/news/archives/05-2016" class="blog-link">May 2016</a>
		<br />
		<a href="/news/archives/04-2016" class="blog-link">April 2016</a>
		<br />
		<a href="/news/archives/03-2016" class="blog-link">March 2016</a>
		<br />
		<a href="/news/archives/02-2016" class="blog-link">February 2016</a>
		<br />
		<a href="/news/archives/01-2016" class="blog-link">January 2016</a>
		<br />
		<a href="/news/archives/12-2015" class="blog-link">December 2015</a>
		<br />
		<a href="/news/archives/11-2015" class="blog-link">November 2015</a>
		<br />
		<a href="/news/archives/10-2015" class="blog-link">October 2015</a>
		<br />
		<a href="/news/archives/09-2015" class="blog-link">September 2015</a>
		<br />
		<a href="/news/archives/08-2015" class="blog-link">August 2015</a>
		<br />
		<a href="/news/archives/07-2015" class="blog-link">July 2015</a>
		<br />
		<a href="/news/archives/06-2015" class="blog-link">June 2015</a>
		<br />
		<a href="/news/archives/05-2015" class="blog-link">May 2015</a>
		<br />
		<a href="/news/archives/04-2015" class="blog-link">April 2015</a>
		<br />
		<a href="/news/archives/03-2015" class="blog-link">March 2015</a>
		<br />
		<a href="/news/archives/02-2015" class="blog-link">February 2015</a>
		<br />
		<a href="/news/archives/01-2015" class="blog-link">January 2015</a>
		<br />
		<a href="/news/archives/12-2014" class="blog-link">December 2014</a>
		<br />
		<a href="/news/archives/11-2014" class="blog-link">November 2014</a>
		<br />
		<a href="/news/archives/10-2014" class="blog-link">October 2014</a>
		<br />
		<a href="/news/archives/09-2014" class="blog-link">September 2014</a>
		<br />
		<a href="/news/archives/08-2014" class="blog-link">August 2014</a>
		<br />
		<a href="/news/archives/07-2014" class="blog-link">July 2014</a>
		<br />
		<a href="/news/archives/06-2014" class="blog-link">June 2014</a>
		<br />
		<a href="/news/archives/05-2014" class="blog-link">May 2014</a>
		<br />
</p>

<div><div style="height: 20px; overflow: hidden; width: 100%;"></div>
<hr class="styled-hr" style="width:100%;"></hr>
<div style="height: 20px; overflow: hidden; width: 100%;"></div></div>

<p class="blog-feed-link">
	<link href=""  rel="alternate" type="application/rss+xml" title="RSS" />
	<a href="/9/feed">
		<img src="//cdn2.editmysite.com/images/old/bg_feed.gif" />
		RSS Feed
	</a>
</p>
		</ul>
	</div>
</div>

	        </td>
	</tr>
</table>

</div>
</div>
				</div>
			</div>
		</div>
		<div id="footer">
			<div id="footer-content"><div class='wsite-elements wsite-footer'>
</div></div>
		</div>
	</div>

	<div class="navmobile-wrapper">
		<div id="navmobile" class="nav"><ul class="wsite-menu-default">
		<li id="pg532739273594404999" class="wsite-menu-item-wrap">
			<a
						href="/"
				class="wsite-menu-item"
				>
				Home
			</a>
			
		</li>
		<li id="pg332450421721364753" class="wsite-menu-item-wrap">
			<a
						href="/community-coverage.html"
				class="wsite-menu-item"
				>
				Community Coverage
			</a>
			
		</li>
		<li id="pg407278629557088076" class="wsite-menu-item-wrap">
			<a
						href="/fantasy.html"
				class="wsite-menu-item"
				>
				Fantasy
			</a>
			<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-731216350653461383"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="/fantasy-rankings.html"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Fantasy Rankings
		</span>
	</a>
	
</li>

	</ul>
</div>

		</li>
		<li id="pg349314906477217206" class="wsite-menu-item-wrap">
			<a
						href="/film-analysis.html"
				class="wsite-menu-item"
				>
				Film Analysis
			</a>
			
		</li>
		<li id="pg424109574749656784" class="wsite-menu-item-wrap">
			<a
						href="/newswire.html"
				class="wsite-menu-item"
				>
				Newswire
			</a>
			
		</li>
		<li id="pg532035896267061933" class="wsite-menu-item-wrap">
			<a
						href="/opinion.html"
				class="wsite-menu-item"
				>
				Opinion
			</a>
			
		</li>
		<li id="pg496326006531464521" class="wsite-menu-item-wrap">
			<a
						href="/podcasts.html"
				class="wsite-menu-item"
				>
				Podcasts
			</a>
			
		</li>
		<li id="pg994901722224474276" class="wsite-menu-item-wrap">
			<a
						href="/schedule.html"
				class="wsite-menu-item"
				>
				Schedule
			</a>
			
		</li>
</ul>
</div>
	</div>

</div>


<script language="javascript" src="/files/theme/plugins.js"></script>
<script language="javascript" src="/files/theme/custom.js"></script>
<script language="javascript" src="/files/theme/mobile.js"></script>

    <div id="customer-accounts-app"></div>
    <script src="//cdn2.editmysite.com/js/site/main-customer-accounts-site.js?buildTime=1535751170"></script>

		<script src="http://www.yardbarker.com/network.js" type="text/javascript"></script><script defer="false" type="text/javascript">_siteid = 13000; yardbar(); </script>

<script src="http://network.yardbarker.com/network/ybn_pixel/13000" type="text/javascript"></script> <noscript></noscript><script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-7870337-1']);
	_gaq.push(['_setDomainName', 'none']);
	_gaq.push(['_setAllowLinker', true]);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wGA = '_gaq';
</script>

<script type="text/javascript" async=1>
	;(function(p,l,o,w,i,n,g){if(!p[i]){p.GlobalSnowplowNamespace=p.GlobalSnowplowNamespace||[];
			p.GlobalSnowplowNamespace.push(i);p[i]=function(){(p[i].q=p[i].q||[]).push(arguments)
			};p[i].q=p[i].q||[];n=l.createElement(o);g=l.getElementsByTagName(o)[0];n.async=1;
			n.src=w;g.parentNode.insertBefore(n,g)}}(window,document,'script','//cdn2.editmysite.com/js/wsnbn/snowday262.js','snowday'));

	var r = [99, 104, 101, 99, 107, 111, 117, 116, 46, 40, 119, 101, 101, 98, 108, 121, 124, 101, 100, 105, 116, 109, 121, 115, 105, 116, 101, 41, 46, 99, 111, 109];
	var snPlObR = function(arr) {
		var s = '';
		for (var i = 0 ; i < arr.length ; i++){
			s = s + String.fromCharCode(arr[i]);
		}
		return s;
	};
	var s = snPlObR(r);

	var regEx = new RegExp(s);

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wSP = 'snowday';
	_W.Analytics.user_id = '57193657';
	_W.Analytics.site_id = '722064618805177267';

	// Setting do not track if the GDPR cookie is not present. This is then checked by the snowday initializer
	// to set tracking decisions. https://github.com/snowplow/snowplow-javascript-tracker/blob/2.6.2/src/js/tracker.js#L1509
	window.doNotTrack = document.cookie.indexOf('gdpr-kb') === -1 ? 'yes' : null;


	(function(app_id, ec_hostname, discover_root_domain) {
		var track = window[_W.Analytics.trackers.wSP];
		if (!track) return;
		track('newTracker', app_id, ec_hostname, {
			appId: app_id,
			post: true,
			platform: 'web',
			discoverRootDomain: discover_root_domain,
			cookieName: '_snow_',
			contexts: {
				webPage: true,
				performanceTiming: true,
				gaCookies: true
			},
			crossDomainLinker: function (linkElement) {
				return regEx.test(linkElement.href);
			},
			respectDoNotTrack: document.cookie.indexOf('gdpr-kb') === -1
		});
		track('trackPageView', _W.Analytics.user_id+':'+_W.Analytics.site_id);
		track('crossDomainLinker', function (linkElement) {
			return regEx.test(linkElement.href);
		});
	})(
		'_wn',
		'ec.editmysite.com',
		true
	);
</script>



<script>
	(function(jQuery) {
		try {
			if (jQuery) {
				jQuery('div.blog-social div.fb-like').attr('class', 'blog-social-item blog-fb-like');
				var $commentFrame = jQuery('#commentArea iframe');
				if ($commentFrame.length > 0) {
					var frameHeight = jQuery($commentFrame[0].contentWindow.document).height() + 50;
					$commentFrame.css('min-height', frameHeight + 'px');
				}
				if (jQuery('.product-button').length > 0){
					jQuery(document).ready(function(){
						jQuery('.product-button').parent().each(function(index, product){
							if(jQuery(product).attr('target') == 'paypal'){
								if (!jQuery(product).find('> [name="bn"]').length){
									jQuery('<input>').attr({
										type: 'hidden',
										name: 'bn',
										value: 'DragAndDropBuil_SP_EC'
									}).appendTo(product);
								}
							}
						});
					});
				}
			}
			else {
				// Prototype
				$$('div.blog-social div.fb-like').each(function(div) {
					div.className = 'blog-social-item blog-fb-like';
				});
				$$('#commentArea iframe').each(function(iframe) {
					iframe.style.minHeight = '410px';
				});
			}
		}
		catch(ex) {}
	})(window._W && _W.jQuery);
</script>

<div id="fb-root"></div>
<script>
	window.fbAsyncInit = function() {
		FB.init({
			appId : '190291501407',
			xfbml : true,
			version : 'v2.6'
		});

        // Set Facebook comment plugin's colorscheme based off of theme
		var comments = document.getElementsByClassName('facebook-comment-widget'),
			scheme = document.body.className.match('wsite-theme-light');

		for (var i = 0; i < comments.length; i++) {
			comments[i].setAttribute('colorscheme', scheme ? 'light' : 'dark');
		}

		var fbCommentCounts;

		FB.Event.subscribe('xfbml.render', function(){
			fbCommentCounts = jQuery('.fb_comments_count');
			for (var i = 0; i < fbCommentCounts.length; i++) {
				var commentText = (jQuery(fbCommentCounts[i]).text() == '1' ? "Comment" : "Comments");
				jQuery(fbCommentCounts[i]).parent().siblings('.fb_comment_count_label').text(commentText);
			}
		});

		var comment_callback = function(res) {
			FB.XFBML.parse(); // Refresh comment counters on page
		}

		FB.Event.subscribe('comment.create', comment_callback);
		FB.Event.subscribe('comment.remove', comment_callback);

	};

	(function(d, s, id){
		var js, fjs = d.getElementsByTagName(s)[0];
		if (d.getElementById(id)) {return;}
		js = d.createElement(s); js.id = id;
		js.src = "//connect.facebook.net/"+_W.facebookLocale+"/sdk.js";
		fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));
</script>
<script type='text/javascript'>
	(function() {
		function j(src, id) {
			var s = document.createElement('script');
			s.type = 'text/javascript';
			s.async = true;
			s.src = src;
			if(id) {s.id=id};
			document.getElementsByTagName('head')[0].appendChild(s);
		}
		j('//platform.twi'+'tter.com/widgets.js');
	})()
</script>
	</body>
</html>
