<!DOCTYPE html>
<html lang="en" xmlns:fb="http://ogp.me/ns/fb#">
	<head>
		<title>Dolphins release veteran LB Lawrence Timmons - PhinManiacs.com</title><meta property="og:site_name" content="PhinManiacs.com" />
<meta property="og:title" content="Dolphins release veteran LB Lawrence Timmons" />
<meta property="og:description" content="The offseason purge continues as it was announced that the Miami Dolphins released veteran linebacker Lawrence Timmons, per ESPN&#039;s Adam Schefter." />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/lawrence-timmons-header-1_1_orig.png" />
<meta property="og:image" content="http://www.phinmaniacs.com/uploads/5/7/1/9/57193657/published/ujqmeosm_1.png?1489034113" />
<meta property="og:url" content="http://www.phinmaniacs.com/9/post/2018/03/dolphins-release-veteran-lb-lawrence-timmons.html" />
<meta http-equiv='cache-control' content='no-cache' />
<meta property="description" content="The offseason purge continues as it was announced that the Miami Dolphins released veteran linebacker Lawrence Timmons, per ESPN&#039;s Adam Schefter." />



<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1.0"/>

		<script type="text/javascript">var GBMobileURL = 'http://mobile.phinmaniacs.com';</script>
<script type="text/javascript" src="http://mobile.phinmaniacs.com/assets/js/detectmobilebrowser.js"></script>

<P> <CENTER>

<script src="https://www.googletagservices.com/tag/js/gpt.js">  googletag.pubads().definePassback("/20893548/yb/phinmaniacs",[728,90]).setClickUrl("%%CLICK_URL_UNESC%%").display(); </script>

<p>
		<link id="wsite-base-style" rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/sites.css?buildTime=1520874378" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/old/fancybox.css?1519426511" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/social-icons.css?buildtime=1519426511" media="screen,projection" />
<link rel="stylesheet" type="text/css" href="/files/main_style.css?1519428468" title="wsite-theme-css" />
<link href='//fonts.googleapis.com/css?family=Raleway:400,300,200,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Lora:400,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />

<link href='//fonts.googleapis.com/css?family=Droid+Sans:400,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//cdn2.editmysite.com/fonts/Saginaw/font.css?2' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Oswald:400,300,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Oswald:400,300,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Playfair+Display:400,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Montserrat:400,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Raleway:400,300,200,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<style type='text/css'>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</style>
<style>
.wsite-background {background-image: url("/uploads/5/7/1/9/57193657/background-images/1366250879.jpg") !important;background-repeat: no-repeat !important;background-position: 50.00% 56.12% !important;background-size: 100% !important;background-color: transparent !important;}
body.wsite-background {background-attachment: fixed !important;}.wsite-background.wsite-custom-background{ background-size: cover !important}
</style>
		<script src='/files/templateArtifacts.js?1519428468'></script>
<script>
var STATIC_BASE = '//cdn1.editmysite.com/';
var ASSETS_BASE = '//cdn2.editmysite.com/';
var STYLE_PREFIX = 'wsite';
</script>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js'></script>

<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1519426511&"></script>
<script src="//cdn2.editmysite.com/js/site/main.js?buildTime=1520874378"></script><script type="text/javascript">_W.configDomain = "www.weebly.com";</script><script>_W.relinquish && _W.relinquish()</script>
<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1520874378&"></script><script> _W.themePlugins = [];</script><script type="text/javascript"> _W.recaptchaUrl = "https://www.google.com/recaptcha/api.js"; </script><script type="text/javascript"> window._W = window._W || {}; _W.showV2Footer = 0; </script><script type="text/javascript"><!--
	
	var DISABLE_NAV_MORE = 1;
	function initFlyouts(){
		initPublishedFlyoutMenus(
			[{"id":"532739273594404999","title":"Home","url":"index.html","target":"","nav_menu":false,"nonclickable":false},{"id":"332450421721364753","title":"Community Coverage","url":"community-coverage.html","target":"","nav_menu":false,"nonclickable":false},{"id":"407278629557088076","title":"Fantasy","url":"fantasy.html","target":"","nav_menu":false,"nonclickable":false},{"id":"349314906477217206","title":"Film Analysis","url":"film-analysis.html","target":"","nav_menu":false,"nonclickable":false},{"id":"424109574749656784","title":"Newswire","url":"newswire.html","target":"","nav_menu":false,"nonclickable":false},{"id":"532035896267061933","title":"Opinion","url":"opinion.html","target":"","nav_menu":false,"nonclickable":false},{"id":"496326006531464521","title":"Podcasts","url":"podcasts.html","target":"","nav_menu":false,"nonclickable":false},{"id":"994901722224474276","title":"Schedule","url":"schedule.html","target":"","nav_menu":false,"nonclickable":false}],
			"833769335793861018",
			'',
			'active',
			false,
			{"navigation\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}} class=\"wsite-menu-item-wrap\">\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\t{{#membership_required}}\n\t\t\tdata-membership-required=\"{{.}}\"\n\t\t{{\/membership_required}}\n\t\tclass=\"wsite-menu-item\"\n\t\t>\n\t\t{{{title_html}}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n","navigation\/flyout\/list":"<div class=\"wsite-menu-wrap\" style=\"display:none\">\n\t<ul class=\"wsite-menu\">\n\t\t{{#children}}{{> navigation\/flyout\/item}}{{\/children}}\n\t<\/ul>\n<\/div>\n","navigation\/flyout\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}}\n\tclass=\"wsite-menu-subitem-wrap {{#is_current}}wsite-nav-current{{\/is_current}}\"\n\t>\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\tclass=\"wsite-menu-subitem\"\n\t\t>\n\t\t<span class=\"wsite-menu-title\">\n\t\t\t{{{title_html}}}\n\t\t<\/span>{{#has_children}}<span class=\"wsite-menu-arrow\">&gt;<\/span>{{\/has_children}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n"},
			{}
		)
	}
//-->
</script>
		
		
	</head>
	<body class="no-header  wsite-page-news wsite-blog-post  full-width-on  wsite-theme-light"><div class="body-wrap">

	<div id="header">
		<div class="nav-trigger hamburger">
			<div class="open-btn">
				<span class="mobile"></span>
				<span class="mobile"></span>
				<span class="mobile"></span>
			</div>
		</div>
		<div id="sitename"><span class="wsite-logo">

	<a href="/">
		<img src="/uploads/5/7/1/9/57193657/published/ujqmeosm_1.png?1489034113" alt="PhinManiacs.com" />
	</a>

</span></div>
	</div>

	<div id="wrapper">
		<div class="bg-wrapper">
			<div id="navigation"><ul class="wsite-menu-default">
		<li id="pg532739273594404999" class="wsite-menu-item-wrap">
			<a
						href="/"
				class="wsite-menu-item"
				>
				Home
			</a>
			
		</li>
		<li id="pg332450421721364753" class="wsite-menu-item-wrap">
			<a
						href="/community-coverage.html"
				class="wsite-menu-item"
				>
				Community Coverage
			</a>
			
		</li>
		<li id="pg407278629557088076" class="wsite-menu-item-wrap">
			<a
						href="/fantasy.html"
				class="wsite-menu-item"
				>
				Fantasy
			</a>
			<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-731216350653461383"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="/fantasy-rankings.html"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Fantasy Rankings
		</span>
	</a>
	
</li>

	</ul>
</div>

		</li>
		<li id="pg349314906477217206" class="wsite-menu-item-wrap">
			<a
						href="/film-analysis.html"
				class="wsite-menu-item"
				>
				Film Analysis
			</a>
			
		</li>
		<li id="pg424109574749656784" class="wsite-menu-item-wrap">
			<a
						href="/newswire.html"
				class="wsite-menu-item"
				>
				Newswire
			</a>
			
		</li>
		<li id="pg532035896267061933" class="wsite-menu-item-wrap">
			<a
						href="/opinion.html"
				class="wsite-menu-item"
				>
				Opinion
			</a>
			
		</li>
		<li id="pg496326006531464521" class="wsite-menu-item-wrap">
			<a
						href="/podcasts.html"
				class="wsite-menu-item"
				>
				Podcasts
			</a>
			
		</li>
		<li id="pg994901722224474276" class="wsite-menu-item-wrap">
			<a
						href="/schedule.html"
				class="wsite-menu-item"
				>
				Schedule
			</a>
			
		</li>
</ul>
</div>
			<div id="content-wrapper">
				<div class="wsite-section-content">
					<div class="container"><div class="wsite-elements wsite-not-footer">
	<table 
	id="blogTable" 
		class="wsite-not-footer" 
	style="border: 0; width: 100%; table-layout: fixed" 
>
	<tr>
	    <td valign="top">
	        	<div id="833769335793861018-blog" class="blog-body" style="float: left;"> 
		<div id="wsite-content">	<div id="blog-post-613432148540391232" class="blog-post">
	
	
		<div class="blog-header">
			<h2 class="blog-title">
					<a class="blog-title-link blog-link" href="//www.phinmaniacs.com/news/dolphins-release-veteran-lb-lawrence-timmons">Dolphins release veteran LB Lawrence Timmons</a>

			</h2>
			<p class="blog-date">
					<span class="date-text">
		3/12/2018
	</span>

			</p>
			<p class="blog-comments">
					<a href="//www.phinmaniacs.com/news/dolphins-release-veteran-lb-lawrence-timmons#comments" class="blog-link">
		<fb:comments-count href="//www.phinmaniacs.com/news/dolphins-release-veteran-lb-lawrence-timmons"></fb:comments-count> <span class="fb_comment_count_label">Comments</span>
	</a>

			</p>
		</div>
	
		<div class="blog-separator">&nbsp;</div>
	
		<div class="blog-content">
				<div><div class="wsite-image wsite-image-border-hairline wsite-image-border-black" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center"> <a> <img src="/uploads/5/7/1/9/57193657/lawrence-timmons-header-1_1_orig.png" alt="Picture" style="width:auto;max-width:100%" /> </a> <div style="display:block;font-size:90%"></div> </div></div>  <div class="paragraph">The offseason purge continues as it was announced that the Miami Dolphins released veteran linebacker Lawrence Timmons, per ESPN's Adam Schefter.<br /><br />While the news about defensive tackle Ndamukong Suh came as a major shock (to anyone not named Jason La Canfora), this news regarding Lawrence Timmons has been reported for weeks, and is only just now being implemented.<br /><br />Timmons, 31, had a total of 84 tackles in 2017, but his very brief Dolphins tenure was marred with drama, as he went AWOL before the beginning of the season, only to return to the field a few weeks later after the team gave him a brief suspension.<br /><br />Now, by releasing Timmons, Miami saves $5,475,000 in cap space while adding $2,750,000 in dead cap, which will already be a significantly high number due to the release of Ndamukong Suh.<br /><br />While Timmons had a strong impact at first, he wore down as the season went on, and eventually became more of a liability than an asset. Now, the Dolphins will once again look to replace his production through free agency and the draft.<br /><br />This "culture change" of the franchise is one that is certainly heartbreaking for fans so far, but only Gase and the rest of the front office knows what they're planning. All we can do, is judge the moves as they come.<br /><br /><strong>This story was written by Luis Sung. Follow him on Twitter: @LuisDSung</strong></div>

		</div>
	
	
			<div class="blog-social  ">
		<div class="blog-social-item blog-fb-like"><fb:like href="http://www.phinmaniacs.com/9/post/2018/03/dolphins-release-veteran-lb-lawrence-timmons.html" width="90" layout="button_count" action="like" show_faces="false" share="false"></fb:like></div><div class="blog-social-item"><a class="twitter-share-button" href="http://twitter.com/share?url=http://www.phinmaniacs.com/9/post/2018/03/dolphins-release-veteran-lb-lawrence-timmons.html" data-text="Dolphins release veteran LB Lawrence Timmons - PhinManiacs.com" data-count="horizontal"></a></div>
		<div style="clear:both"></div>
	</div>

	
		<div class="blog-comments-bottom">
				<a href="//www.phinmaniacs.com/news/dolphins-release-veteran-lb-lawrence-timmons#comments" class="blog-link">
		<fb:comments-count href="//www.phinmaniacs.com/news/dolphins-release-veteran-lb-lawrence-timmons"></fb:comments-count> <span class="fb_comment_count_label">Comments</span>
	</a>

		</div>
	
		<div class="blog-post-separator"></div>
	</div>


    <a name="comments" id="comments"></a>
<div id="commentArea">
	<div class="blog-comment-area">
				<fb:comments 
			href="http://www.phinmaniacs.com/news/dolphins-release-veteran-lb-lawrence-timmons"
			numposts="50" 
			order_by="reverse_time" 
			colorscheme="light" 
			class="facebook-comment-widget"
			width="100%"
		></fb:comments>



	</div>
	<!-- bid-1: , path:  -->
</div>
 
<!-- bid: $blog_id --></div>
	</div>

	    </td>
	        <td class="blog-sidebar" valign="top">
	            <div id="833769335793861018-sidebar" class="column-blog">
	<div class="blog-sidebar-separator">
		<ul id="833769335793861018-sidebar-list" class="columnlist-blog" style="margin:0; padding: 0;">
			<div><div id="714951839612077782" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><!-- start feedwind code --><script type="text/javascript">document.write('<script type="text/javascript" src="' + ('https:' == document.location.protocol ? 'https://' : 'http://') + 'feed.mikle.com/js/rssmikle.js"><' + '/script>');</script><script type="text/javascript">(function() {var params = {rssmikle_url: "http://www.phinmaniacs.com/9/feed",rssmikle_frame_width: "200",rssmikle_frame_height: "325",rssmikle_target: "_top",rssmikle_font: "Arial",rssmikle_font_size: "12",rssmikle_border: "on",responsive: "off",rssmikle_css_url: "",text_align: "left",text_align2: "left",corner: "on",scrollbar: "on",autoscroll: "off",scrolldirection: "up",scrollstep: "5",mcspeed: "30",sort: "New",rssmikle_title: "off",rssmikle_title_sentence: "",rssmikle_title_link: "",rssmikle_title_bgcolor: "#0066FF",rssmikle_title_color: "#FFFFFF",rssmikle_title_bgimage: "",rssmikle_item_bgcolor: "#FFFFFF",rssmikle_item_bgimage: "",rssmikle_item_title_length: "275",rssmikle_item_title_color: "#347093",rssmikle_item_border_bottom: "on",rssmikle_item_description: "title_only",item_link: "off",rssmikle_item_description_length: "150",rssmikle_item_description_color: "#8B8B8B",rssmikle_item_date: "gl2",rssmikle_timezone: "America/Toronto",datetime_format: "%b %e, %Y %l:%M:%S %p",item_description_style: "text",item_thumbnail: "full",article_num: "35",rssmikle_item_podcast: "off",keyword_inc: "",keyword_exc: ""};feedwind_show_widget_iframe(params);})();</script></div>



</div>

<h2 class="wsite-content-title" style="text-align:left;"><font size="4">Latest Dolphins News</font></h2>

<div class="wsite-spacer" style="height:10px;"></div>

<div class="wsite-spacer" style="height:10px;"></div>

<div><div id="242556355631298790" align="center" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><script src="https://www.googletagservices.com/tag/js/gpt.js"> googletag.pubads().definePassback("/20893548/yb/phinmaniacs", [160,600]).setClickUrl("%%CLICK_URL_UNESC%%").display(); </script></div>



</div>

<h2 class="blog-category-title" style="text-align:left;"><font size="4">PhinManiacs Columnists</font></h2>
<p class="blog-category-list">
	<a href="/news/category/all" class="blog-link">All</a>
	<br />
		<a href="/news/category/carlos-hernandez" class="blog-link">Carlos Hernandez</a>
		<br />
		<a href="/news/category/chad-ronnebaum" class="blog-link">Chad Ronnebaum</a>
		<br />
		<a href="/news/category/community-coverage" class="blog-link">Community Coverage</a>
		<br />
		<a href="/news/category/daniel-gamboa" class="blog-link">Daniel Gamboa</a>
		<br />
		<a href="/news/category/efrain-ramos" class="blog-link">Efrain Ramos</a>
		<br />
		<a href="/news/category/Eldon Jenson" class="blog-link">Eldon Jenson</a>
		<br />
		<a href="/news/category/eldon-jenson" class="blog-link">Eldon Jenson</a>
		<br />
		<a href="/news/category/fantasy-football" class="blog-link">Fantasy Football</a>
		<br />
		<a href="/news/category/film-analysis" class="blog-link">Film Analysis</a>
		<br />
		<a href="/news/category/hagop-taraksian" class="blog-link">Hagop Taraksian</a>
		<br />
		<a href="/news/category/ian-berger" class="blog-link">Ian Berger</a>
		<br />
		<a href="/news/category/lake-prasad" class="blog-link">Lake Prasad</a>
		<br />
		<a href="/news/category/luis-sung" class="blog-link">Luis Sung</a>
		<br />
		<a href="/news/category/matthew-knowles" class="blog-link">Matthew Knowles</a>
		<br />
		<a href="/news/category/miami-dolphins-cheerleaders" class="blog-link">Miami Dolphins Cheerleaders</a>
		<br />
		<a href="/news/category/nate-tucek" class="blog-link">Nate Tucek</a>
		<br />
		<a href="/news/category/neal-driscoll" class="blog-link">Neal Driscoll</a>
		<br />
		<a href="/news/category/opinion" class="blog-link">Opinion</a>
		<br />
		<a href="/news/category/phinmaniacs-podcast" class="blog-link">PhinManiacs Podcast</a>
		<br />
		<a href="/news/category/press-releases" class="blog-link">Press Releases</a>
		<br />
		<a href="/news/category/richard-wilt" class="blog-link">Richard Wilt</a>
		<br />
		<a href="/news/category/ron-canniff" class="blog-link">Ron Canniff</a>
		<br />
		<a href="/news/category/ryan-thyer" class="blog-link">Ryan Thyer</a>
		<br />
		<a href="/news/category/seth-fisher" class="blog-link">Seth Fisher</a>
		<br />
		<a href="/news/category/tom-shannon" class="blog-link">Tom Shannon</a>
		<br />
</p>

<h2 class="blog-archives-title" style="text-align:left;"><font size="3">Story Archives</font></h2>
<p class="blog-archive-list">
		<a href="/news/archives/02-2018" class="blog-link">February 2018</a>
		<br />
		<a href="/news/archives/01-2018" class="blog-link">January 2018</a>
		<br />
		<a href="/news/archives/11-2017" class="blog-link">November 2017</a>
		<br />
		<a href="/news/archives/10-2017" class="blog-link">October 2017</a>
		<br />
		<a href="/news/archives/09-2017" class="blog-link">September 2017</a>
		<br />
		<a href="/news/archives/08-2017" class="blog-link">August 2017</a>
		<br />
		<a href="/news/archives/07-2017" class="blog-link">July 2017</a>
		<br />
		<a href="/news/archives/06-2017" class="blog-link">June 2017</a>
		<br />
		<a href="/news/archives/05-2017" class="blog-link">May 2017</a>
		<br />
		<a href="/news/archives/04-2017" class="blog-link">April 2017</a>
		<br />
		<a href="/news/archives/03-2017" class="blog-link">March 2017</a>
		<br />
		<a href="/news/archives/02-2017" class="blog-link">February 2017</a>
		<br />
		<a href="/news/archives/01-2017" class="blog-link">January 2017</a>
		<br />
		<a href="/news/archives/12-2016" class="blog-link">December 2016</a>
		<br />
		<a href="/news/archives/11-2016" class="blog-link">November 2016</a>
		<br />
		<a href="/news/archives/10-2016" class="blog-link">October 2016</a>
		<br />
		<a href="/news/archives/09-2016" class="blog-link">September 2016</a>
		<br />
		<a href="/news/archives/08-2016" class="blog-link">August 2016</a>
		<br />
		<a href="/news/archives/07-2016" class="blog-link">July 2016</a>
		<br />
		<a href="/news/archives/06-2016" class="blog-link">June 2016</a>
		<br />
		<a href="/news/archives/05-2016" class="blog-link">May 2016</a>
		<br />
		<a href="/news/archives/04-2016" class="blog-link">April 2016</a>
		<br />
		<a href="/news/archives/03-2016" class="blog-link">March 2016</a>
		<br />
		<a href="/news/archives/02-2016" class="blog-link">February 2016</a>
		<br />
		<a href="/news/archives/01-2016" class="blog-link">January 2016</a>
		<br />
		<a href="/news/archives/12-2015" class="blog-link">December 2015</a>
		<br />
		<a href="/news/archives/11-2015" class="blog-link">November 2015</a>
		<br />
		<a href="/news/archives/10-2015" class="blog-link">October 2015</a>
		<br />
		<a href="/news/archives/09-2015" class="blog-link">September 2015</a>
		<br />
		<a href="/news/archives/08-2015" class="blog-link">August 2015</a>
		<br />
		<a href="/news/archives/07-2015" class="blog-link">July 2015</a>
		<br />
		<a href="/news/archives/06-2015" class="blog-link">June 2015</a>
		<br />
		<a href="/news/archives/05-2015" class="blog-link">May 2015</a>
		<br />
		<a href="/news/archives/04-2015" class="blog-link">April 2015</a>
		<br />
		<a href="/news/archives/03-2015" class="blog-link">March 2015</a>
		<br />
		<a href="/news/archives/02-2015" class="blog-link">February 2015</a>
		<br />
		<a href="/news/archives/01-2015" class="blog-link">January 2015</a>
		<br />
		<a href="/news/archives/12-2014" class="blog-link">December 2014</a>
		<br />
		<a href="/news/archives/11-2014" class="blog-link">November 2014</a>
		<br />
		<a href="/news/archives/10-2014" class="blog-link">October 2014</a>
		<br />
		<a href="/news/archives/09-2014" class="blog-link">September 2014</a>
		<br />
		<a href="/news/archives/08-2014" class="blog-link">August 2014</a>
		<br />
		<a href="/news/archives/07-2014" class="blog-link">July 2014</a>
		<br />
		<a href="/news/archives/06-2014" class="blog-link">June 2014</a>
		<br />
		<a href="/news/archives/05-2014" class="blog-link">May 2014</a>
		<br />
</p>

<div><div style="height: 20px; overflow: hidden; width: 100%;"></div>
<hr class="styled-hr" style="width:100%;"></hr>
<div style="height: 20px; overflow: hidden; width: 100%;"></div></div>

<p class="blog-feed-link">
	<link href=""  rel="alternate" type="application/rss+xml" title="RSS" />
	<a href="/9/feed">
		<img src="//cdn2.editmysite.com/images/old/bg_feed.gif" />
		RSS Feed
	</a>
</p>
		</ul>
	</div>
</div>

	        </td>
	</tr>
</table>

</div>
</div>
				</div>
			</div>
		</div>
		<div id="footer">
			<div id="footer-content"><div class='wsite-elements wsite-footer'>
</div></div>
		</div>
	</div>

	<div class="navmobile-wrapper">
		<div id="navmobile" class="nav"><ul class="wsite-menu-default">
		<li id="pg532739273594404999" class="wsite-menu-item-wrap">
			<a
						href="/"
				class="wsite-menu-item"
				>
				Home
			</a>
			
		</li>
		<li id="pg332450421721364753" class="wsite-menu-item-wrap">
			<a
						href="/community-coverage.html"
				class="wsite-menu-item"
				>
				Community Coverage
			</a>
			
		</li>
		<li id="pg407278629557088076" class="wsite-menu-item-wrap">
			<a
						href="/fantasy.html"
				class="wsite-menu-item"
				>
				Fantasy
			</a>
			<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-731216350653461383"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="/fantasy-rankings.html"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Fantasy Rankings
		</span>
	</a>
	
</li>

	</ul>
</div>

		</li>
		<li id="pg349314906477217206" class="wsite-menu-item-wrap">
			<a
						href="/film-analysis.html"
				class="wsite-menu-item"
				>
				Film Analysis
			</a>
			
		</li>
		<li id="pg424109574749656784" class="wsite-menu-item-wrap">
			<a
						href="/newswire.html"
				class="wsite-menu-item"
				>
				Newswire
			</a>
			
		</li>
		<li id="pg532035896267061933" class="wsite-menu-item-wrap">
			<a
						href="/opinion.html"
				class="wsite-menu-item"
				>
				Opinion
			</a>
			
		</li>
		<li id="pg496326006531464521" class="wsite-menu-item-wrap">
			<a
						href="/podcasts.html"
				class="wsite-menu-item"
				>
				Podcasts
			</a>
			
		</li>
		<li id="pg994901722224474276" class="wsite-menu-item-wrap">
			<a
						href="/schedule.html"
				class="wsite-menu-item"
				>
				Schedule
			</a>
			
		</li>
</ul>
</div>
	</div>

</div>


<script language="javascript" src="/files/theme/plugins.js"></script>
<script language="javascript" src="/files/theme/custom.js"></script>
<script language="javascript" src="/files/theme/mobile.js"></script>


		<script src="http://www.yardbarker.com/network.js" type="text/javascript"></script><script defer="false" type="text/javascript">_siteid = 13000; yardbar(); </script>

<script src="http://network.yardbarker.com/network/ybn_pixel/13000" type="text/javascript"></script> <noscript></noscript><script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-7870337-1']);
	_gaq.push(['_setDomainName', 'none']);
	_gaq.push(['_setAllowLinker', true]);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wGA = '_gaq';

</script>

<script type="text/javascript" async=1>
	;(function(p,l,o,w,i,n,g){if(!p[i]){p.GlobalSnowplowNamespace=p.GlobalSnowplowNamespace||[];
			p.GlobalSnowplowNamespace.push(i);p[i]=function(){(p[i].q=p[i].q||[]).push(arguments)
			};p[i].q=p[i].q||[];n=l.createElement(o);g=l.getElementsByTagName(o)[0];n.async=1;
			n.src=w;g.parentNode.insertBefore(n,g)}}(window,document,'script','//cdn2.editmysite.com/js/wsnbn/snowday262.js','snowday'));

	var r = [99, 104, 101, 99, 107, 111, 117, 116, 46, 40, 119, 101, 101, 98, 108, 121, 124, 101, 100, 105, 116, 109, 121, 115, 105, 116, 101, 41, 46, 99, 111, 109];
	var snPlObR = function(arr) {
		var s = '';
		for (var i = 0 ; i < arr.length ; i++){
			s = s + String.fromCharCode(arr[i]);
		}
		return s;
	};
	var s = snPlObR(r);

	var regEx = new RegExp(s);

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wSP = 'snowday';
	_W.Analytics.user_id = '57193657';
	_W.Analytics.site_id = '722064618805177267';


	(function(app_id, ec_hostname, discover_root_domain) {
		var track = window[_W.Analytics.trackers.wSP];
		if (!track) return;
		track('newTracker', app_id, ec_hostname, {
			appId: app_id,
			post: true,
			platform: 'web',
			discoverRootDomain: discover_root_domain,
			cookieName: '_snow_',
			contexts: {
				webPage: true,
				performanceTiming: true,
				gaCookies: true
			},
			crossDomainLinker: function (linkElement) {
				return regEx.test(linkElement.href);
			}
		});
		track('trackPageView', _W.Analytics.user_id+':'+_W.Analytics.site_id);
		track('crossDomainLinker', function (linkElement) {
			return regEx.test(linkElement.href);
		});
	})(
		'_wn',
		'ec.editmysite.com',
		true
	);
</script>

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = "https://secure.quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-0dYLvhSGGqUWo",
labels:"l10,u57193657.u57193657s722064618805177267"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-0dYLvhSGGqUWo.gif?labels=l10,u57193657.u57193657s722064618805177267" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


<script>

	(function(jQuery) {
		try {
			if (jQuery) {
				jQuery('div.blog-social div.fb-like').attr('class', 'blog-social-item blog-fb-like');
				var $commentFrame = jQuery('#commentArea iframe');
				if ($commentFrame.length > 0) {
					var frameHeight = jQuery($commentFrame[0].contentWindow.document).height() + 50;
					$commentFrame.css('min-height', frameHeight + 'px');
				}
				if (jQuery('.product-button').length > 0){
					jQuery(document).ready(function(){
						jQuery('.product-button').parent().each(function(index, product){
							if(jQuery(product).attr('target') == 'paypal'){
								if (!jQuery(product).find('> [name="bn"]').length){
									jQuery('<input>').attr({
										type: 'hidden',
										name: 'bn',
										value: 'DragAndDropBuil_SP_EC'
									}).appendTo(product);
								}
							}
						});
					});
				}
			}
			else {
				// Prototype
				$$('div.blog-social div.fb-like').each(function(div) {
					div.className = 'blog-social-item blog-fb-like';
				});
				$$('#commentArea iframe').each(function(iframe) {
					iframe.style.minHeight = '410px';
				});
			}
		}
		catch(ex) {}
	})(window._W && _W.jQuery);

</script>
<div id="eu-cookie" class="notification" style="display: none;">
	<span id="eu-cookie-content"></span>
	<span id="eu-cookie-close">&#10005;</span>
</div>

<script type="text/javascript">
	(function($) {
		window.cookie_location = '';
		// this cookie_content should already be pre-encoded from CookieSettingView.js
		window.cookie_content = '' || _W.stl('templates.publish.virtual-includes.footerCode_1');
		window.cookie_policy_key = '722064618805177267_cookie_policy';
		window.cookie_content_hash = '';

		if (!_W.getCookie(window.cookie_policy_key) || _W.getCookie(window.cookie_policy_key) !== window.cookie_content_hash){
			if (window.cookie_location === 'top' || window.cookie_location === 'bottom'){
				$('#eu-cookie-content').text(decodeURIComponent(window.cookie_content));
				(window.cookie_location === 'top') ? animateFromTop() : animateFromBottom();
				$('#eu-cookie').show();
			}
		}

		$('#eu-cookie-close').click(function(){
			_W.setCookie(window.cookie_policy_key, window.cookie_content_hash, 100000);
			$('#eu-cookie').hide();
		});

		function animateFromTop(){
			$('#eu-cookie').css({
				'top': '0px',
				'animation': 'reveal-top 1 2s'
			});
		}

		function animateFromBottom(){
			$('#eu-cookie').css({
				'bottom': '0px',
				'animation': 'reveal-bottom 1 2s'
			});
		}
	})(window._W && _W.jQuery);
</script>
<div id="fb-root"></div>
<script>
	window.fbAsyncInit = function() {
		FB.init({
			appId : '190291501407',
			xfbml : true,
			version : 'v2.6'
		});

        // Set Facebook comment plugin's colorscheme based off of theme
		var comments = document.getElementsByClassName('facebook-comment-widget'),
			scheme = document.body.className.match('wsite-theme-light');

		for (var i = 0; i < comments.length; i++) {
			comments[i].setAttribute('colorscheme', scheme ? 'light' : 'dark');
		}

		var fbCommentCounts;

		FB.Event.subscribe('xfbml.render', function(){
			fbCommentCounts = jQuery('.fb_comments_count');
			for (var i = 0; i < fbCommentCounts.length; i++) {
				var commentText = (jQuery(fbCommentCounts[i]).text() == '1' ? "Comment" : "Comments");
				jQuery(fbCommentCounts[i]).parent().siblings('.fb_comment_count_label').text(commentText);
			}
		});

		var comment_callback = function(res) {
			FB.XFBML.parse(); // Refresh comment counters on page
		}

		FB.Event.subscribe('comment.create', comment_callback);
		FB.Event.subscribe('comment.remove', comment_callback);

	};

	(function(d, s, id){
		var js, fjs = d.getElementsByTagName(s)[0];
		if (d.getElementById(id)) {return;}
		js = d.createElement(s); js.id = id;
		js.src = "//connect.facebook.net/"+_W.facebookLocale+"/sdk.js";
		fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));
</script>
<script type='text/javascript'>
	(function() {
		function j(src, id) {
			var s = document.createElement('script');
			s.type = 'text/javascript';
			s.async = true;
			s.src = src;
			if(id) {s.id=id};
			document.getElementsByTagName('head')[0].appendChild(s);
		}
		j('//platform.twi'+'tter.com/widgets.js');
	})()
</script>
	</body>
</html>
